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Information 
Manual version: 0.1 

Author: Olaf Abbenhuis 

Copyright: ICEPAY B.V. 

 

1.1 Overview 

This module enables the use of ICEPAY payment methods in your Open Cart webshop. 

Module webpage: 

http://www.icepay.com/webshop-modules/online-payments-for-opencart 

 

1.2 Releases 

The list of releases is available online: 

http://www.icepay.com/webshop-modules/online-payments-for-opencart 

 

1.3 Compatibility 

The compatibility chart is available online: 

http://www.icepay.com/webshop-modules/online-payments-for-opencart 

  

1.4 Requirements 

You need the following requirements to be able to use the module: 

Software  

OpenCart See Compatibility 

  

http://www.icepay.com/webshop-modules/online-payments-for-opencart
http://www.icepay.com/webshop-modules/online-payments-for-opencart
http://www.icepay.com/webshop-modules/online-payments-for-opencart
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2 Installation 

2.1 Manual installation 

 

Step 1. Download and unzip 

Download the module and unzip it to a folder on your computer. 

 

Step 2. Upload 

Upload the files as followed: 

Module folder Place in 

upload/admin /admin 

upload/catalog /catalog 

upload/image /image 

 

 

 

Step 3. Install the module within OpenCart 

Log in to your administrator backend:  

Browse to Action 

Extensions -> Payment -> ICEPAY Install 

 

The module is now installed and ready for configuration. 

Read configuration for more information. 
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2.2 Adding languages 

 

The module comes with the following languages installed out-of-the-box: 

Language Language file locations for both admin and catalog 

English english/payment/icepay_basic.php 

Dutch dutch/payment/icepay_basic.php 

 

Language files 

To add a language, new files need to be added. It is recommended to copy the English files 

as a basis for the new language. Then place the translations in the new file. 

Without those files the module will break while viewed in the new language. 

Translation for Language file locations (* marks the language folder) 

Admin /admin/language/*/payment/icepay_basic.php 

Catalog /catalog/language/*/payment/icepay_basic.php 

 

For example to add the German (DE) language, the following files need to be added: 

Translation for Language file locations 

Admin /admin/language/german/payment/icepay_basic.php 

Catalog /catalog/language/german/payment/icepay_basic.php 

 

Admin configuration 

To complete the installation, the Description in checkout needs to be updated for the 

customer. 

Log in to your administrator backend:  

Browse to Action 

Extensions -> Payment -> ICEPAY -> Edit -> Appearance tab Above the Description in Checkout are 
tabs for each installed language. Enter 
a description for the new language. 
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3 Upgrade 

3.1 Module 

It is recommended to always have the latest version of the module. 

To upgrade the module, follow step 1 & 2 mentioned in the Installation chapter. The 

configuration is stored within the database and will not be overwritten. 

Check all configuration settings of the module after an installation. It is possible some 

settings have changed or added. 
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4 Uninstall 

4.1 Module 

To uninstall the module, log in to your administrator backend:  

Browse to Action 

Extensions -> Payment -> ICEPAY Uninstall 
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5 Configuration 

5.1 First use 

 

Step 1. Open the configuration section 

To configure the module, log in to your administrator backend:  

Browse to Action 

Extensions -> Payment -> ICEPAY Edit 

 

Step 2. Link an ICEPAY merchant website 

Use the generated Merchant URLs to create a new Merchant website in your ICEPAY 

account. 

Copy the Merchant URLs one by one. See Image 1 

Once you have created a merchant, you will receive a Merchant ID and Secret Code. Copy-

paste these into the corresponding OpenCart boxes. See Image 2. 
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Image 1: Use the URLs generated by the ICEPAY Basic module to create an ICEPAY merchant website. 
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Image 2: Use the Merchant ID and Secret Code of your new Merchant website to complete the link. 

 

Step 3. Statuscodes 

It is vital to set the status codes appropriately. Go to the Status codes tab and change them 

to fit your website.  

Read the settings section for information related to the status code settings. 

Save the settings and ICEPAY is ready to be used. 
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6 Settings information 

6.1 Options 

 

Browse to Action 

Extensions -> Payment -> ICEPAY Edit 

 

Merchant settings tab 

Options Description Recommended setting 

URL for success Merchant ‘Thank You’ page Nothing to change 

URL for error Merchant ‘Error’ page Nothing to change 

URL for postback Merchant ‘Postback’ page Nothing to change 

Merchant ID Required to link a merchant 
(Read: Configuration, First use) 

 

Secret Code Required to link a merchant 
(Read: Configuration, First use) 

 

Total  Minimum amount required for 
ICEPAY to show as payment 
method in checkout 

0 

Geo Zone Restrict ICEPAY to a certain geo 
zone. 

All Zones 

Status Turn the module on or off Enabled 

Sort order The display order of ICEPAY in 
checkout 

1 

 

Statuscodes tab 

Options Description Recommended setting 

Pending Payment Status Order created but no payment 
information available yet 

Pending 

Payment Accepted Status The payment has been received 
completely 

Processing 

Payment Error Status An error occurred or the customer 
cancelled the transaction 

Failed 

Payment Chargeback Status A chargeback has been 
requested 

Chargeback 

Payment Refund Status A refund has been processed Refunded 
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Appearance tab 

Customize the information displayed during the customer checkout. Image 3 displays a 

checkout example. 

Options Description Recommended setting 

Display ICEPAY Logo Display the ICEPAY logo. 
In case the designer would like to 
alter the image, for example to 
display the iDeal and Paypal logo. 
The image can be found at: 
/image/icepay/icepay_basic.png 

Yes 

Description in checkout This text will be shown to the 
customer. (If the ICEPAY logo is 
displayed, the text will be shown 
underneath the image) 
The description can be set per 
language. 
In case both are empty the default 
text will display “Paypal and iDeal 
using ICEPAY” 

A text tailored to the available 
payment methods. Such as 
“Pay with iDeal or Paypal” 

 

Image 3 

About tab 

Contains version information and support links. 
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7 License conditions 
 

Definitions 

ICEPAY payment module 

The software product provided by ICEPAY B.V. on an ‘as is’ basis without any warranty of any kind.  

License 

A written public act of the Dutch central bank or other governmental body which provides ICEPAY B.V. 
with these rights. 
 

 

User license conditions webshop module 

This User License Agreement applies to the use of this ICEPAY webshop module, as 

supplied by ICEPAY  B.V. (further referred to as ICEPAY B.V.).  

BY USING ICEPAY WEBSHOP MODULE YOU FULLY AGREE TO THE CONDITIONS OF 

THIS USER LICENSE AGREEMENT. IF YOU DO NOT AGREE TO THIS LICENSE 

AGREEMENT, YOU SHOULD REFRAIN FROM USING THE ICEPAY WEBSHOP 

MODULE. 

You may only use the ICEPAY webshop module if such is directly obtained from ICEPAY 

B.V. and downloaded from www.icepay.com and if you or the organization where you work 

has entered into an official contract with ICEPAY B.V. and therefore is a Customer in 

accordance with these conditions. 

This User License Agreement and the use of the ICEPAY webshop module are governed by 

the laws of The Netherlands. Any disagreement will be placed before a qualified court in The 

Hague, The Netherlands. The United Nations Convention on Contracts for the International 

Sale of Goods (CISG) is not applicable. 

 

User license ICEPAY webshop module  

ICEPAY B.V. grants Customer the non-exclusive right to use this ICEPAY webshop module 

and corresponding documentation. The license shall go into effect after Customer has 

fulfilled all its obligations. 

The license is limited exclusively to own use of the ICEPAY webshop module for the agreed 

upon Central Processing Unit (CPU), number of users, servers, websites, 0900 numbers, 

and/or workstations. If no limitations have been agreed upon, the license will be limited to the 

CPU on which the ICEPAY webshop module was first installed and the number of users, 

servers, websites, 0900 numbers, and/or workstations will be limited to 1 (one). Customer is 
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allowed to make one back-up copy of the ICEPAY webshop module for safety purposes only, 

if a back-up is not provided for by ICEPAY B.V. 

This license for this ICEPAY webshop module is limited to the object code. Rights to the 

source code are not provided, unless explicitly agreed upon otherwise in writing. The license 

with regard to this ICEPAY webshop module for which ICEPAY B.V. has a License is limited 

to use within the framework of the applicable License.  

It is prohibited for Customer directly or indirectly (through a third party) to copy or duplicate 

the ICEPAY webshop module in any way, without the prior written approval from ICEPAY 

B.V. The license to use the ICEPAY webshop module cannot be transferred to any third 

party (third parties also include holding, affiliated, and/or subsidiary companies). Customer 

does not have the right to make the ICEPAY webshop module available, under any title or in 

any way whatsoever, to any third party (third parties also include holding, affiliated, and/or 

subsidiary companies). 

Customer is authorized to alter (in the source code) the ICEPAY webshop module. Any 

alterations are the sole responsibility and risk of Customer. All work performed by ICEPAY 

B.V. related to a support question on an ICEPAY webshop module whose code has been 

changed (to some extent, however small) shall be charged to Customer on the basis of 

actual costs in accordance with the standard rates of ICEPAY B.V. 

 

Warranty disclaimer 

The ICEPAY webshop module is made available on an “as is” basis only and without any 

warranty or indemnity of any kind.  

ICEPAY B.V. makes no warranties, conditions, indemnities, representations or terms, 

express or implied, whether by statute, custom, or otherwise as to any other matters, 

including but not limited to non-infringement of third party rights, integration, accuracy, 

security, availability, satisfactory quality, merchantability or fitness for any particular purpose. 

 

Limitations to indemnification & liability  

Customer agrees to indemnify ICEPAY B.V. from all liability, losses, actions, damages or 

claims (including all reasonable costs and attorney costs) which flow forth or are regarding 

the use or dependency upon the ICEPAY webshop module.   

Under no circumstances will ICEPAY B.V. be liable to Customer, or any other person or 

entity, for any loss of use, revenue or profit, lost or damaged data, or other commercial or 

economic loss or for any direct, indirect, special, statutory, or consequential damages 

whatsoever related to the use or reliance upon ICEPAY webshop module, even if advised of 

the possibility of such damages or if such damages are foreseeable. This limitation shall 

apply to each breach of this User License Agreement by ICEPAY B.V. 
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Additional work & support 

All activities that ICEPAY B.V. must perform upon request of Customer related to the use of 

the ICEPAY webshop module, which has been made available at no charge, shall be 

invoiced as additional work (or support) on the basis of actual costs according to the 

applicable rates of ICEPAY B.V.  

(Future) incompatibility problems (products are unable to interoperate with each other) can 

be resolved on the basis of additional work.  

It will be assumed that Customer has agreed with the performance of additional work and the 

connected costs, if Customer has allowed additional work to take place without raising 

objections in writing prior to the commencement of additional work.  

 

Installation and implementation 

ICEPAY B.V. will only install and/or implement the ICEPAY webshop module or have it 

installed and/or implemented if agreed upon in writing.  

Prior to installation and/or implementation Customer will see to it, at its own expense, that all 

conditions required by ICEPAY B.V. have been met in order to ensure a successful 

installation and/or implementation. 

Customer will ensure and is entirely responsible for fulfilling the conditions of the necessary 

software licenses in order to let installation and/or implementation take place legally. 

 

Duration 

This agreement is effective as of the moment of acceptance and may be terminated at any 

time by ICEPAY B.V. whereby a notice period of one week shall apply. 

 

General conditions/applicability 

The General Conditions ICEPAY apply to the agreement. The applicability of purchase 

conditions or any other conditions from Customer or third parties is, then, expressly rejected 

by ICEPAY B.V. Customer explicitly declares to have received the General Conditions 

ICEPAY and to agree with the General Conditions ICEPAY. 

 

 

 


